AmxModX [1.8.3] dev

perfectblood0

Команда форума
Администратор
Регистрация
29 Окт 2017
Сообщения
1.224
Симпатии
377
#1
Не вижу смысла что то описывать.
Периодически буду стараться обновлять версии с выходом новых
Сборка: 5175
Мультиязычность: есть
ОС: Win & Linux
 

Вложения

Последнее редактирование модератором:

Vesuvius

НЕ СКРИПТЕР!!!
Команда форума
Администратор
Регистрация
8 Июн 2017
Сообщения
1.466
Симпатии
486
Пол
Мужской
#4
perfectblood0, о том что содержимое архивов не полное...
 

perfectblood0

Команда форума
Администратор
Регистрация
29 Окт 2017
Сообщения
1.224
Симпатии
377
#5

Vesuvius

НЕ СКРИПТЕР!!!
Команда форума
Администратор
Регистрация
8 Июн 2017
Сообщения
1.466
Симпатии
486
Пол
Мужской
#6
perfectblood0, тут нету модулей
  • cstrike_amxx_i386.so
  • csx_amxx_i386.so
 

Вложения

Последнее редактирование: Vesuvius

Vesuvius

НЕ СКРИПТЕР!!!
Команда форума
Администратор
Регистрация
8 Июн 2017
Сообщения
1.466
Симпатии
486
Пол
Мужской
#8
Обновил 1 пост!
  • Обновлен AmxModX на Linux до версии 5154 (архив собран полностью)
  • Обновлен AmxModX на Windows до версии 5154 (архив собран полностью)
 
Последнее редактирование: Vesuvius

Vesuvius

НЕ СКРИПТЕР!!!
Команда форума
Администратор
Регистрация
8 Июн 2017
Сообщения
1.466
Симпатии
486
Пол
Мужской
#9
Обновил 1 пост!
  • Обновлен AmxModX на Linux до версии 5175 (архив собран полностью)
  • Обновлен AmxModX на Windows до версии 5175 (архив собран полностью)
 

Vesuvius

НЕ СКРИПТЕР!!!
Команда форума
Администратор
Регистрация
8 Июн 2017
Сообщения
1.466
Симпатии
486
Пол
Мужской
#11
я так понимаю 1.8.3 вовсе убрали с линейки???
оставили 1.8.2 и 1.9.0?
а нет .. нашол...

кто уже ставил 1.9.0... как полет?
 

perfectblood0

Команда форума
Администратор
Регистрация
29 Окт 2017
Сообщения
1.224
Симпатии
377
#12
я так понимаю 1.8.3 вовсе убрали с линейки???
оставили 1.8.2 и 1.9.0?
Вроде как ничего существенного, Радиус как то писал об этом в чате. По его словам переходить на 1.9 не лучшее решение
 

kpacava

Пользователь
Регистрация
14 Июл 2017
Сообщения
73
Симпатии
13
Пол
Мужской
#13
perfectblood0, Почему не лучшее решение?
Переход же не резкий а с 1.8.3 плавный на 1.9 - возможно будет дальнейшем будет кардинальные изменения...
Но щас это тот же 1.8.3 с потенциалом!
 

perfectblood0

Команда форума
Администратор
Регистрация
29 Окт 2017
Сообщения
1.224
Симпатии
377
#14
perfectblood0, Почему не лучшее решение?
Переход же не резкий а с 1.8.3 плавный на 1.9 - возможно будет дальнейшем будет кардинальные изменения...
Но щас это тот же 1.8.3 с потенциалом!
Версии не различаются только цифрами. Там же разные структуры и функции.
 

kpacava

Пользователь
Регистрация
14 Июл 2017
Сообщения
73
Симпатии
13
Пол
Мужской
#17
на данный момент всё ровно работает! да и на 1.8.2 и на 1.8.3 и щас на 1.9 ровно работает!
только с компиляцией 1.8.3 были траблы, но не че они решаемы!
Поглядим что дальше будет...
 

kapangaIII

Команда форума
Разработчик
Регистрация
31 Окт 2017
Сообщения
411
Симпатии
127
#18
я так понимаю 1.8.3 вовсе убрали с линейки???
оставили 1.8.2 и 1.9.0?
а нет .. нашол...

кто уже ставил 1.9.0... как полет?
1.8.3 == 1.9.0, просто у француза немного странное восприятие, он почему-то решил ориентироваться на переход клиентов на нью билд, но он обосрется с ru, если не принесет им поддержку 5ххх билдов с кЛёВоЙ стрельбой в амхмоде новом, при этом он как-то наплевательски отнёсся к релизу 1.8.3, диз из бэд, ведь все равно будут плагины писать лишь разработчики. В общем смена версии - лишь для привлечения серверо держателей, чтобы они там не орали что 1.8.3 уже старый и продукт не умер как в прошлом.


По его словам переходить на 1.9 не лучшее решение
Ну если ему нравятся утечки повсюду на 1.8.2, то пускай и дальше вручную переносит их.
Q4a6-ysaqfw.jpg

Очевидно что сравнивают 1.8.2 с 1.8.3(1.9.0), лишь появление папки data/gamedata со смещениями, которую многие игнорируют, затем появляются темы 'амхмод не работает, откачусь ка я обратно'.

Про поддержку 1.8.2, по хорошему от нее нужно отказаться (да и давно наверное) в некоторых случаях, например лишь потому что там невозможно нормально работать с юникодом без написания своих функций на павне :/
 
Последнее редактирование: kapangaIII

Radius

Пользователь
Регистрация
10 Июн 2017
Сообщения
103
Симпатии
116
Пол
Мужской
#19
kapangaIII, эти утечки не критичны, это доказано годами использования. В таком же ключе можно сказать и про новые версии, "Вы хотите новых нераспознанных утечек и багов, которые из-за снижающейся активности скорее всего не найдут и не пофиксят". Я например лично знаю несколько багов, которые тянутся с 1.8.2 и перекочевали успешно в 1.8.3. Каждый раз улыбаюсь, найдя в 1.8.2 и проверяя остался ли он в 1.8.3.

Отличий между 1.8.2 и 1.9.0 намного больше. Самая главная что старшая версия всегда привязана к последним билдам, а старые билды всегда игнорируются. Поражает что разрабы спокойно игнорируют время жизни версии. Не прикидывают сколько кода было написано, чтобы взять и прекратить поддержку и заметьте, повторю это сколько надо раз, не предоставив релиз взамен.

Все в 1.8.2 нормально с юникодом, все плагины работают с русским языком. Хотелки скриптеров, ради их удобства, это не аргумент для конечного пользователя.
 

fantom

Пользователь
Регистрация
11 Июн 2017
Сообщения
183
Симпатии
97
Пол
Мужской
#20
просто у француза немного странное восприятие
тут скорее та же история что и с PHP 6. Дурная слава. Плюс изменений много в сравнении 1.8.2. А вообше то имхо апнули цыферку с 8 на 9 и поноса как с ведра. Особенно со стороны одного всеми известними персонажа, который вылазит раз в год из норы повонять "поддержка" бла бла бла.
14 Сен 2018
Особенно забавил тот факт, что все работать не будет. Хотя достаточно из плагинов выпилять колорчат с дхудом в 90% случаев и вуаля - успешно работает на 190